Your Location is: Home > Eclipse

How to configure JBoss 5.1.0GA using JDK1.6 on Eclipse 2018-12 and Fedora 29?

From: Phnom Penh View: 2600 marcosnasp 

Question

I'm trying to configure JBoss AS Server on Eclipse 2018-12, but I can not create a server Jboss 5.1.0.GA using Jboss Tools 4.9.0.Final. The Error message is: 'This server requires an execution environment from J2SE-1.4 through JavaSE-1.8, but no valid JRE was found. Caution is advised.'

Error Message - Add Server

Even Though I have changed the Execution Environment, I can not find a compatible JRE Execution (JDK 1.6) for the Environment Execution.

Compatible JRE Execution

Previously I have configured the Installed JRE with a JDK 6.0, but I have noticed that some jars files are not present at moment of config, that are:

  • jre/lib/resources.jar;
  • jre/lib/jsse.jar;
  • jre/lib/jce.jar;
  • jre/lib/charsets.jar.

Libs not present

These jars present on oracle jdk_1.6.0_45 are visible at moment of config in the case of Ubuntu 18.04, but on Fedora 29, it is not present.

How can I configure to make possible to add JBoss server, and make it running on JDK1.6?

Best answer

I tried your configuration on a F29 VM. Here's what I did:

  • installed JDK1.6.0_45 (from Oracle)
  • installed 2018-12
  • launched 2018-12
  • installed JBoss Tools server adapters
  • tried to add a JBoss 5.1 but noticed it was not possible
  • removed Java 11 (sudo yum remove java-11-openjdk-headless)
  • installed Java 8 (sudo yum install java-1.8.0-openjdk-devel)
  • relanched 2018-12
  • got an error while creating the JBoss 5.1 server
  • noticed in the error log JDK1.6.0 is missing the libnsl.so.1)
  • installed libnsl (sudo yum install libnsl)
  • create and start server were now successful

Hope this helps